Builds are failing on some accounts
Incident Report for Codefresh
Postmortem

Impact:

We had 40 minutes where API calls relying on context objects were failing.

Detection:

Our internal monitoring detected this issue.

Root Cause:

We introduced a new security model to our context API, and as a result, caused a callback loop between that API and another service.

Resolution:

We reverted the code within 40 minutes of our internal monitoring raising an alert and have reimplemented the new security model in a way that doesn’t cause the callback loop.

Posted Jun 20, 2023 - 00:08 UTC

Resolved
This incident has been resolved.
Posted Jun 08, 2023 - 17:23 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 08, 2023 - 13:13 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 08, 2023 - 12:57 UTC
Investigating
We are currently investigating this issue.
Posted Jun 08, 2023 - 12:51 UTC
This incident affected: Codefresh Systems (codefresh.io).