Quay.io incident is impacting some image pulls
Incident Report for Codefresh
Resolved
Quay.io is operating correctly for pushes and pulls.
This issue is resolved for all Codefresh related operations.
Posted Nov 15, 2023 - 21:43 UTC
Monitoring
Quay.io has implemented fix for the issue and is operating for image pulls. Codefresh default image pulls are functional at this time.
We are continuing to monitor Codefresh builds.
Posted Nov 15, 2023 - 00:34 UTC
Identified
We are seeing improved success rate at this time in image pulls from Quay for Codefresh build images. We are continuing to monitor the incident status from Quay.io.
Posted Nov 14, 2023 - 23:28 UTC
Update
As a partial workaround to help alleviate the issue, users can set the default marketplace registry to pull from Docker Hub. This setting will make all public typed-steps (excluding direct Freestyle steps) pull images from the specified registry.

To configure this, you will first need a registry integration in your Codefresh account for Docker Hub.
Then go to account settings -> Pipeline Settings -> Advanced Options -> Public Marketplace Registry, and select your Docker Hub integration in the dropdown.

Note that this setting only affects public typed-step image pulls such as codefresh-run, and will not resolve Quay image pull issues for other cases.
Image pulls will also be subject to any Docker Hub rate limits associated with your credentials.
Posted Nov 14, 2023 - 21:55 UTC
Investigating
An incident at Quay.io (https://status.quay.io/incidents/z7sbjqmb34p1) is impacting some pipeline builds, causing failures when the required images are unable to be obtained.
Posted Nov 14, 2023 - 21:03 UTC
This incident affected: Codefresh Systems (Codefresh Classic Pipeline Engine).