We are experiencing issues with viewing GitOps-related pages in UI
Incident Report for Codefresh
Postmortem

We have completed our RCA for this incident, for which the summary is below:

Impact:
We had significant disruption to any UI page that relied on displaying runtime-related information, leading to incomplete or unavailable data for users.

Detection:
This issue was reported to us by customers.

Root Cause:
An unexpected side effect of an API change which caused the event handler to not recognize runtime events as runtimes and instead treat them as generic-entities. When the change was reverted the entries in the generic-entities collection were no longer updated, and an automatic cleaning function then resulted in some UI data queries returning incorrect data.

Resolution:
After resolving the root cause, we rebuilt the required data and reinitialized the runtime information. We have identified improvements to our E2E testing process and monitoring systems as a result of this incident that we will be implementing.

Posted Nov 20, 2023 - 20:02 UTC

Resolved
This incident has been resolved.
Posted Nov 13, 2023 - 20:21 UTC
Monitoring
We have implemented additional fixes to restore UI functionality, and we are monitoring the results.
Posted Nov 13, 2023 - 18:51 UTC
Identified
We have identified an additional issue and are working on a fix.
Posted Nov 13, 2023 - 18:04 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 13, 2023 - 17:47 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 13, 2023 - 15:48 UTC
Update
We are continuing to investigate this issue.
Posted Nov 13, 2023 - 14:23 UTC
Investigating
We are currently investigating this issue.
Posted Nov 13, 2023 - 13:32 UTC
This incident affected: Codefresh Systems (Codefresh GitOps UI).