Codefresh CI Pipeline Runs Failing Due to Image Pull Failure

Incident Report for Codefresh

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 07:20 UTC

Update

Quay.io has restored image pull & push functionality. Codefresh systems should no longer be affected. We are continuing to monitor.
Posted Mar 30, 2026 - 23:19 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 30, 2026 - 21:17 UTC

Monitoring

Codefresh CI Pipeline runs may fail due to image pull issues with our upstream provider (quay.io). Customers may experience intermittent issues with pulling/pushing quay.io-based images while this incident is being addressed.
Posted Mar 30, 2026 - 21:13 UTC
This incident affected: Codefresh Systems (Codefresh Classic Steps Marketplace, Codefresh Classic Pipeline Engine).