GitHub upstream outage impacting Classic Pipelines (and other GH dependent services)

Incident Report for Codefresh

Resolved

Github Git Operations is operating normally as of Nov 18, 2025 - 21:56 UTC
Posted Nov 18, 2025 - 21:58 UTC

Monitoring

It appears that GitHub has shipped a fix, and we're monitoring the recovery now.
Posted Nov 18, 2025 - 21:37 UTC

Identified

As of 20:39 UTC GitHub reported an outage impacting all related git operations. As a result, this will affect the ability to clone/push/pull from GitHub repositories.

For more information regarding the GitHub outage, please visit: https://www.githubstatus.com/
Posted Nov 18, 2025 - 21:17 UTC
This incident affected: GitHub (GitHub) and Codefresh Systems (Codefresh Classic Pipeline Engine).