An ongoing AWS US East outage is causing platform degradation

Incident Report for Codefresh

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 19:49 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 19:33 UTC

Monitoring

SaaS builds are now operating normally. We are continuing to monitor the situation and the current AWS outage.
Posted Oct 20, 2025 - 18:49 UTC

Update

We are still working on migrating to an unaffected region.

For critical pipelines, a workaround is to install a Hybrid Pipeline Runtime in a region unaffected by the AWS outage. Once installed, configure the pipeline to use this Hybrid Runtime.
Posted Oct 20, 2025 - 18:01 UTC

Update

We're seeing an increase impact of degreated performance across the platform. We're still working to migrating to another unaffected region at this time.
Posted Oct 20, 2025 - 15:58 UTC

Update

To mitigate issues around the regional AWS outage, we're working on migrating to an unaffected region. We'll update as the migration progresses and continue to monitor the situation.
Posted Oct 20, 2025 - 15:33 UTC

Update

AWS is still seeing connectivity issues in US-East region. We’re still monitoring the situation and will update as we have more information as it related to the platform.
Posted Oct 20, 2025 - 15:18 UTC

Update

SaaS builds are seeing increased retry rates due to ongoing EC2 issues on AWS. We've applied mitigations to reduce the impact, but some delays may still occur. AWS is still reporting EC2 as affected. We’re monitoring the situation and will update as we have more information.
Posted Oct 20, 2025 - 13:41 UTC

Update

Platform performance remains impacted by the issue, we are continuing to monitor it.
Posted Oct 20, 2025 - 10:27 UTC

Identified

We've started the recovery process after the AWS outage and are performing multiple checks to ensure everything is back to normal
Posted Oct 20, 2025 - 10:12 UTC
This incident affected: Codefresh Systems (codefresh.io, Codefresh Classic UI, Codefresh GitOps UI, Codefresh Classic Pipeline Engine, Codefresh GitOps Metadata and Metrics, Codefresh Classic GitOps Dashboard).