Sporadic connection timeouts while operating with cm://h.cfcr.io
Incident Report for Codefresh
Resolved
This incident has been resolved.
Posted Sep 13, 2023 - 18:57 UTC
Investigating
Currently some users might encounter issues while operating with default Helm registry cm://h.cfcr.io.
We're investigating this issue.

Some errors that might be seen in build:

Error: Get https://h.cfcr.io/account/default/index.yaml: net/http: request canceled (Client.Timeout exceeded while awaiting headers)
Error: looks like "cm://h.cfcr.io/account/default/" is not a valid chart repository or cannot be reached: plugin "bin/helmpush" exited with error

or

Error: 500: unknown error
Error: looks like "cm://g.codefresh.io/api/helm/repos/account/default/" is not a valid chart repository or cannot be reached: plugin "bin/helm-cm-push" exited with error

~~
Workaround:

As a temporary workaround, we recommend adding retry options to your helm-related steps as described here: https://codefresh.io/docs/docs/pipelines/what-is-the-codefresh-yaml/#retrying-a-step
Posted Sep 13, 2023 - 15:24 UTC
This incident affected: Codefresh Systems (Codefresh Helm Museum).