Some Classic builds are stuck in Pending state
Incident Report for Codefresh
Postmortem

Impact: Some accounts sporadically experienced longer pending times than usual on a portion of their builds for a day.

Detection: Issue was reported by a customer, and shortly after confirmed by Codefresh’s platform monitoring alerts.

Root Cause: This issue was caused by a bug in MongoDB driver. The MongoDB driver was upgraded in Codefresh services as part of our efforts to improve performance, but this version contained a bug that caused Mongoose queries to hang when under heavy load without returning or throwing errors. This resulted in the Codefresh build manager randomly getting stuck when enough queries were hanging under certain conditions.

Resolution: A temporary solution to improve build queries queue behavior was initially implemented to alleviate the issue for affected customers. The actual root cause was identified the following week, and the issue was resolved by downgrading the MongoDB driver to a version that did not contain the bug.

Posted Oct 10, 2024 - 14:45 UTC

Resolved
This incident has been resolved.
Posted Sep 23, 2024 - 20:14 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 23, 2024 - 14:21 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 23, 2024 - 13:39 UTC
Investigating
We are currently investigating this issue.
Posted Sep 23, 2024 - 13:34 UTC
This incident affected: Codefresh Systems (Codefresh Classic Pipeline Engine).