Performance issues with the Codefresh platform

Incident Report for Codefresh

Resolved

This incident has now been resolved. We will conduct further investigations into the load experienced by our backend for specific operations from a small number of customers, and provide details of our findings.
Posted Feb 16, 2026 - 01:44 UTC

Investigating

The Codefresh platform is experiencing some intermittent performance issues which are currently being investigated. We will update as we know more.
Posted Feb 16, 2026 - 00:29 UTC
This incident affected: Codefresh Systems (Codefresh Classic SLA, Codefresh GitOps SLA, codefresh.io, Codefresh Classic UI, Codefresh GitOps UI, Codefresh API, Codefresh Hosted GitOps Services, Codefresh Classic Steps Marketplace, Codefresh Classic Pipeline Engine, Codefresh Helm Museum, Codefresh GitOps Metadata and Metrics, Codefresh File Distribution, Codefresh Classic GitOps Dashboard, Codefresh Classic Webhook Endpoints, Codefresh Classic Datadog Enpoint).