h.cfcr.io is not reachable
Incident Report for Codefresh
Postmortem

Impact: Codefresh default helm repository was unreachable from h.cfcr.io. Classic users relying on this were unable to run their builds until they switched to our backup endpoint.

Detection: This was discovered by a user.

Root Cause: There were issues with our DNS provider. The workaround that was provided to users during this outage can be considered a permanent fix.

Posted Feb 24, 2023 - 19:06 UTC

Resolved
At this time, all DNS issues have been resolved for cfcr.io.

To reiterate, if you have implemented the workaround which uses the https://g.codefresh.io/api/helm/repos endpoint, you can safely leave this workaround in place, or revert back to https://h.cfcr.io if you wish to do so.

If you are seeing any issues with cfcr.io please reach out to Codefresh Support for assistance.
Posted Feb 21, 2023 - 19:30 UTC
Monitoring
DNS issues for cfcr.io are resolved as DNS propagation has been completed. All customers (both SaaS and Hybrid) should now be able to access the Codefresh Chart Musemum using cfcr.io.

Please note: If you have implemented the workaround which uses the https://g.codefresh.io/api/helm/repos endpoint, you can safely leave this workaround in place, or revert back to https://h.cfcr.io if you wish to do so.

We are going to continue to monitor the situation prior to marking this incident as resolved.
Posted Feb 21, 2023 - 17:58 UTC
Update
DNS issues for cfcr.io are now resolved for all non-hybrid customers. Hybrid customers may still experience some issues, therefore we are continuing to monitor the situation.
Posted Feb 21, 2023 - 17:40 UTC
Update
The issue was identified with our DNS provider. The current timeline for a resolution could be up to three days.

In the meantime you can change all references to the helm registry (https://h.cfcr.io) to the direct endpoint of: https://g.codefresh.io/api/helm/repos

These changes should be made in the following places:

1. Codefresh helm integration (https://g.codefresh.io/account-admin/account-conf/integration/helmNew)
2. Pipelines with freestyle step
3. External systems to codefresh which are referencing the helm registry

Please feel free to reach out to support with any questions.
Posted Feb 21, 2023 - 16:26 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 21, 2023 - 12:47 UTC
Investigating
We are currently investigating this issue.
Posted Feb 21, 2023 - 12:26 UTC
This incident affected: Codefresh Systems (Codefresh Helm Museum).