codefresh.io is intermittently unreachable for some users

Incident Report for Codefresh

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 00:42 UTC

Monitoring

Most regions are online; however, a few remain unavailable. For the latest news please check https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 21:22 UTC

Update

CloudFlare is continuing to work on restoring services. Please follow https://www.cloudflarestatus.com/ for more details
Posted Nov 18, 2025 - 13:50 UTC

Identified

The issue has been identified and is due to a CloudFlare outage. Please follow https://www.cloudflarestatus.com/ for more details
The updated list of affected Codefresh systems:
- codefresh.io website - docs and marketing content
- steps catalog
- Argo hub website (for Argo workflow templates)
Posted Nov 18, 2025 - 12:21 UTC

Investigating

The codefresh.io page and argohub pages are intermittently unreachable for some users.
g.codefresh.io remains unaffected.
We are currently investigating the issue.
Posted Nov 18, 2025 - 12:07 UTC
This incident affected: Codefresh Systems (codefresh.io).